12 October 2008

Vlan Configuration



Untuk Swtch Lt 1 Paling pojok kanan Ata

Switch_Lt1# vlan database
Switch_Lt1(vlan)# vlan 10 name keuangan ==> create vlan 10 dengan nama keuangan
Switch_Lt1(vlan)# vlan 20 name produksi
Switch_Lt1(vlan)# exit
Switch_Lt1# config terminal
Switch_Lt1(config)# interface fastethernet 0/10
Switch_Lt1(config-if)# switchport mode trunk
Switch_Lt1(config-if)# switchport trunk encapsulation dot1q
Switch_Lt1(config-if)# exit
Switch_Lt1(config)# interface fastethernet 0/1
Switch_Lt1(config-if)# switchport mode access
Switch_Lt1(config-if)# switchport access vlan 10 ==> 10 = VLAN yang kita assignkan di port fastethernet 0/1
Switch_Lt1(config)# interface fastethernet 0/2
Switch_Lt1(config-if)# switchport mode access
Switch_Lt1(config-if)# switchport access vlan 10
Switch_Lt1(config)# interface fastethernet 0/3
Switch_Lt1(config-if)# switchport mode access
Switch_Lt1(config-if)# switchport access vlan 20
Switch_Lt1(config)# interface fastethernet 0/4
Switch_Lt1(config-if)# switchport mode access
Switch_Lt1(config-if)# switchport access vlan 20
Switch_Lt1# copy running-config startup-config

===================================
Untuk Switch Lantai 2 yang terhubung dengan Router

Switch_Lt2# vlan database
Switch_Lt2(vlan)# vlan 10 name keuangan
Switch_Lt2(vlan)# vlan 20 name produksi
Switch_Lt2(vlan)# vlan 30 name penjualan
Switch_Lt2(vlan)# vlan 40 name HRD
Switch_Lt2# config terminal
Switch_Lt2(config)# interface fastethernet 0/10
Switch_Lt2(config-if)# switchport mode trunk
Switch_Lt2(config-if)# switchport trunk encapsulation dot1q
Switch_Lt2(config)# interface fastethernet 0/9
Switch_Lt2(config-if)# switchport mode trunk
Switch_Lt2(config-if)# switchport trunk encapsulation dot1q
Switch_Lt2(config)# interface fastethernet 0/8
Switch_Lt2(config-if)# switchport mode trunk
Switch_Lt2(config-if)# switchport trunk encapsulation dot1q
Switch_Lt2(config)# interface fastethernet 0/1
Switch_Lt2(config-if)# switchport mode access
Switch_Lt2(config-if)# switchport access vlan 10
Switch_Lt2(config)# interface fastethernet 0/2
Switch_Lt2(config-if)# switchport mode access
Switch_Lt2(config-if)# switchport access vlan 20
Switch_Lt2(config)# interface fastethernet 0/3
Switch_Lt2(config-if)# switchport mode access
Switch_Lt2(config-if)# switchport access vlan 30
Switch_Lt2(config)# interface fastethernet 0/4
Switch_Lt2(config-if)# switchport mode access
Switch_Lt2(config-if)# switchport access vlan 40
Switch_Lt1# copy running-config startup-config

============================================
Untuk Switch Lantai 3 yang paling kiri bawah

Switch_Lt3# vlan database
Switch_Lt3(vlan)# vlan 30 name penjualan
Switch_Lt3(vlan)# vlan 50 name IT
Switch_Lt3(vlan)# exit
Switch_Lt3# configure terminal
Switch_Lt3(config)# interface fastethernet 0/10
Switch_Lt3(config-if)# switchport mode trunk
Switch_Lt3(config-if)# switchport trunk encapsulation dot1q
Switch_Lt3(config)# interface fastethernet 0/1
Switch_Lt3(config-if)# switchport mode access
Switch_Lt3(config-if)# switchport access vlan 30
Switch_Lt3(config)# interface fastethernet 0/2
Switch_Lt3(config-if )# switchport mode access
Switch_Lt3(config-if)# switchport access vlan 30
Switch_Lt3(config)# interface fastethernet 0/3
Switch_Lt3(config-if)# switchport mode access
Switch_Lt3(config-if)# switchport access vlan 50
Switch_Lt3(config)# interface fastethernet 0/4
Switch_Lt3(config-if)# switchport mode access
Switch_Lt3(config-if)# switchport access vlan 50
Switch_Lt3# copy running-config startup-config

====================================

Untuk Setingan Router yang thub k Vlan

Rtr_VLAN# configure terminal
Rtr_VLAN(config)# interface fastethernet 0/0
Rtr_VLAN(config-if)# no shutdown ==> Menghidupkan interface fa0/0
Rtr_VLAN(config)# interface fastethernet 0/0.10
Rtr_VLAN(config-subif)# encapsulation dot1q 10
Rtr_VLAN(config-subif)# ip address 192.168.1.1 255.255.255.0
Rtr_VLAN(config)# interface fastethernet 0/0.20
Rtr_VLAN(config-subif)# encapsulation dot1q 20
Rtr_VLAN(config-subif)# ip address 192.168.2.1 255.255.255.0
Rtr_VLAN(config)# interface fastethernet 0/0.30
Rtr_VLAN(config-subif)# encapsulation dot1q 30
Rtr_VLAN(config-subif)# ip address 192.168.3.1 255.255.255.0
Rtr_VLAN(config)# interface fastethernet 0/0.40
Rtr_VLAN(config-subif)# encapsulation dot1q 40
Rtr_VLAN(config)# ip address 192.168.4.1 255.255.255.0
Rtr_VLAN(config)# interface fastethernet 0/0.50
Rtr_VLAN(config-subif)# encapsulation dot1q 50
Rtr_VLAN(config-subif)# ip address 192.168.5.1 255.255.255.0
Rtr_VLAN# copy running-config startup-config

Router>ena
Router#
Router#sh
Router#show run
Router#show running-config

Building configuration...

Current configuration : 874 bytes
!
version 12.4
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname Router
!
boot-start-marker
boot-end-marker
!
!
!
!
no aaa new-model
!
!
ip cef
!
!
!
!
!
ip subnet-zero
!
!
!
!
!
!
!
!
!
!
interface FastEthernet0/0
no ip address
no ip directed-broadcast
!
interface FastEthernet0/0.10
encapsulation dot1Q 10
ip address 192.168.1.1 255.255.255.0
!
interface FastEthernet0/0.20
ip address 192.168.2.1 255.255.255.0
!
interface FastEthernet0/0.30
ip address 192.168.3.1 255.255.255.0
!
interface FastEthernet0/0.40
ip address 192.168.4.1 255.255.255.0
!
interface FastEthernet0/0.50
ip address 192.168.5.1 255.255.255.0
!
interface FastEthernet0/1
no ip address
no ip directed-broadcast
shutdown
!
interface Serial0/0/0
no ip address
no ip directed-broadcast
shutdown
!
interface Serial0/0/1
no ip address
no ip directed-broadcast
shutdown
!
interface Serial0/1/0
no ip address
no ip directed-broadcast
shutdown
!
interface Serial0/1/1
no ip address
no ip directed-broadcast
shutdown
!
!
ip classless
no ip http server
no ip http secure-server
!
!
!
!
!
!
control-plane
!
!
!
!
line con 0
line aux 0
line vty 0 4
login
line vty 5 1180
login
!
scheduler allocate 20000 1000
!
end

Router#

07 October 2008

Routing Cisco




















Basic Routing Protocol With a 3 Router n 3 Switch n than 6 host, 2 host include 1 switc
router1#show run (router1)
Current configuration:
!
version 12.0
service timestamps debug uptime
service timestamps log uptime
no service password-encryption
!
hostname router1
!
!
!
ip subnet-zero
!
interface Ethernet0
ip address 192.168.1.1 255.255.255.0
no ip directed-broadcast
!
interface Serial0
ip address 202.47.1.1 255.255.255.252
no ip directed-broadcast
clock rate 56000
no ip mroute-cache
!
interface Serial1
no ip address
no ip directed-broadcast
shutdown
!
!
no ip classless
ip route 192.168.3.0 255.255.255.0 202.47.2.2
ip route 192.168.2.0 255.255.255.0 202.47.1.2
!
!
!
line con 0
password amal
login
line aux 0
line vty 0 4
password amal
login
!
end
=======================
router3#show running-config
Current configuration:
!
version 12.0
service timestamps debug uptime
service timestamps log uptime
no service password-encryption
!
hostname router3
!
!
!
ip subnet-zero
!
interface Ethernet0
ip address 192.168.2.1 255.255.255.0
no ip directed-broadcast
!
interface Serial0
ip address 202.47.2.1 255.255.255.252
no ip directed-broadcast
shutdown
clock rate 56000
!
interface Serial1
ip address 202.47.1.2 255.255.255.252
no ip directed-broadcast
no ip mroute-cache
!
!
no ip classless
ip route 192.168.3.0 255.255.255.0 202.47.2.2
ip route 192.168.1.0 255.255.255.0 202.47.1.1
!
!
!
line con 0
password amal
login
line aux 0
line vty 0 4
password amal
login
!
end
=========================
router4#show running-config
Current configuration:
!
version 12.0
service timestamps debug uptime
service timestamps log uptime
no service password-encryption
!
hostname router4
!
!
!
ip subnet-zero
!
interface Ethernet0
ip address 192.168.3.0 255.255.255.0
no ip directed-broadcast
!
interface Serial0
no ip address
no ip directed-broadcast
shutdown
!
interface Serial1
ip address 202.47.2.2 255.255.255.252
no ip directed-broadcast
no ip mroute-cache
!
!
no ip classless
ip route 192.168.2.0 255.255.255.0 202.47.2.1
ip route 192.168.1.0 255.255.255.0 202.47.1.1
!
!
!
line con 0
password amal
login
line aux 0
line vty 0 4
password amal
login
!
end

12 October 2008

Vlan Configuration



Untuk Swtch Lt 1 Paling pojok kanan Ata

Switch_Lt1# vlan database
Switch_Lt1(vlan)# vlan 10 name keuangan ==> create vlan 10 dengan nama keuangan
Switch_Lt1(vlan)# vlan 20 name produksi
Switch_Lt1(vlan)# exit
Switch_Lt1# config terminal
Switch_Lt1(config)# interface fastethernet 0/10
Switch_Lt1(config-if)# switchport mode trunk
Switch_Lt1(config-if)# switchport trunk encapsulation dot1q
Switch_Lt1(config-if)# exit
Switch_Lt1(config)# interface fastethernet 0/1
Switch_Lt1(config-if)# switchport mode access
Switch_Lt1(config-if)# switchport access vlan 10 ==> 10 = VLAN yang kita assignkan di port fastethernet 0/1
Switch_Lt1(config)# interface fastethernet 0/2
Switch_Lt1(config-if)# switchport mode access
Switch_Lt1(config-if)# switchport access vlan 10
Switch_Lt1(config)# interface fastethernet 0/3
Switch_Lt1(config-if)# switchport mode access
Switch_Lt1(config-if)# switchport access vlan 20
Switch_Lt1(config)# interface fastethernet 0/4
Switch_Lt1(config-if)# switchport mode access
Switch_Lt1(config-if)# switchport access vlan 20
Switch_Lt1# copy running-config startup-config

===================================
Untuk Switch Lantai 2 yang terhubung dengan Router

Switch_Lt2# vlan database
Switch_Lt2(vlan)# vlan 10 name keuangan
Switch_Lt2(vlan)# vlan 20 name produksi
Switch_Lt2(vlan)# vlan 30 name penjualan
Switch_Lt2(vlan)# vlan 40 name HRD
Switch_Lt2# config terminal
Switch_Lt2(config)# interface fastethernet 0/10
Switch_Lt2(config-if)# switchport mode trunk
Switch_Lt2(config-if)# switchport trunk encapsulation dot1q
Switch_Lt2(config)# interface fastethernet 0/9
Switch_Lt2(config-if)# switchport mode trunk
Switch_Lt2(config-if)# switchport trunk encapsulation dot1q
Switch_Lt2(config)# interface fastethernet 0/8
Switch_Lt2(config-if)# switchport mode trunk
Switch_Lt2(config-if)# switchport trunk encapsulation dot1q
Switch_Lt2(config)# interface fastethernet 0/1
Switch_Lt2(config-if)# switchport mode access
Switch_Lt2(config-if)# switchport access vlan 10
Switch_Lt2(config)# interface fastethernet 0/2
Switch_Lt2(config-if)# switchport mode access
Switch_Lt2(config-if)# switchport access vlan 20
Switch_Lt2(config)# interface fastethernet 0/3
Switch_Lt2(config-if)# switchport mode access
Switch_Lt2(config-if)# switchport access vlan 30
Switch_Lt2(config)# interface fastethernet 0/4
Switch_Lt2(config-if)# switchport mode access
Switch_Lt2(config-if)# switchport access vlan 40
Switch_Lt1# copy running-config startup-config

============================================
Untuk Switch Lantai 3 yang paling kiri bawah

Switch_Lt3# vlan database
Switch_Lt3(vlan)# vlan 30 name penjualan
Switch_Lt3(vlan)# vlan 50 name IT
Switch_Lt3(vlan)# exit
Switch_Lt3# configure terminal
Switch_Lt3(config)# interface fastethernet 0/10
Switch_Lt3(config-if)# switchport mode trunk
Switch_Lt3(config-if)# switchport trunk encapsulation dot1q
Switch_Lt3(config)# interface fastethernet 0/1
Switch_Lt3(config-if)# switchport mode access
Switch_Lt3(config-if)# switchport access vlan 30
Switch_Lt3(config)# interface fastethernet 0/2
Switch_Lt3(config-if )# switchport mode access
Switch_Lt3(config-if)# switchport access vlan 30
Switch_Lt3(config)# interface fastethernet 0/3
Switch_Lt3(config-if)# switchport mode access
Switch_Lt3(config-if)# switchport access vlan 50
Switch_Lt3(config)# interface fastethernet 0/4
Switch_Lt3(config-if)# switchport mode access
Switch_Lt3(config-if)# switchport access vlan 50
Switch_Lt3# copy running-config startup-config

====================================

Untuk Setingan Router yang thub k Vlan

Rtr_VLAN# configure terminal
Rtr_VLAN(config)# interface fastethernet 0/0
Rtr_VLAN(config-if)# no shutdown ==> Menghidupkan interface fa0/0
Rtr_VLAN(config)# interface fastethernet 0/0.10
Rtr_VLAN(config-subif)# encapsulation dot1q 10
Rtr_VLAN(config-subif)# ip address 192.168.1.1 255.255.255.0
Rtr_VLAN(config)# interface fastethernet 0/0.20
Rtr_VLAN(config-subif)# encapsulation dot1q 20
Rtr_VLAN(config-subif)# ip address 192.168.2.1 255.255.255.0
Rtr_VLAN(config)# interface fastethernet 0/0.30
Rtr_VLAN(config-subif)# encapsulation dot1q 30
Rtr_VLAN(config-subif)# ip address 192.168.3.1 255.255.255.0
Rtr_VLAN(config)# interface fastethernet 0/0.40
Rtr_VLAN(config-subif)# encapsulation dot1q 40
Rtr_VLAN(config)# ip address 192.168.4.1 255.255.255.0
Rtr_VLAN(config)# interface fastethernet 0/0.50
Rtr_VLAN(config-subif)# encapsulation dot1q 50
Rtr_VLAN(config-subif)# ip address 192.168.5.1 255.255.255.0
Rtr_VLAN# copy running-config startup-config

Router>ena
Router#
Router#sh
Router#show run
Router#show running-config

Building configuration...

Current configuration : 874 bytes
!
version 12.4
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname Router
!
boot-start-marker
boot-end-marker
!
!
!
!
no aaa new-model
!
!
ip cef
!
!
!
!
!
ip subnet-zero
!
!
!
!
!
!
!
!
!
!
interface FastEthernet0/0
no ip address
no ip directed-broadcast
!
interface FastEthernet0/0.10
encapsulation dot1Q 10
ip address 192.168.1.1 255.255.255.0
!
interface FastEthernet0/0.20
ip address 192.168.2.1 255.255.255.0
!
interface FastEthernet0/0.30
ip address 192.168.3.1 255.255.255.0
!
interface FastEthernet0/0.40
ip address 192.168.4.1 255.255.255.0
!
interface FastEthernet0/0.50
ip address 192.168.5.1 255.255.255.0
!
interface FastEthernet0/1
no ip address
no ip directed-broadcast
shutdown
!
interface Serial0/0/0
no ip address
no ip directed-broadcast
shutdown
!
interface Serial0/0/1
no ip address
no ip directed-broadcast
shutdown
!
interface Serial0/1/0
no ip address
no ip directed-broadcast
shutdown
!
interface Serial0/1/1
no ip address
no ip directed-broadcast
shutdown
!
!
ip classless
no ip http server
no ip http secure-server
!
!
!
!
!
!
control-plane
!
!
!
!
line con 0
line aux 0
line vty 0 4
login
line vty 5 1180
login
!
scheduler allocate 20000 1000
!
end

Router#

07 October 2008

Routing Cisco




















Basic Routing Protocol With a 3 Router n 3 Switch n than 6 host, 2 host include 1 switc
router1#show run (router1)
Current configuration:
!
version 12.0
service timestamps debug uptime
service timestamps log uptime
no service password-encryption
!
hostname router1
!
!
!
ip subnet-zero
!
interface Ethernet0
ip address 192.168.1.1 255.255.255.0
no ip directed-broadcast
!
interface Serial0
ip address 202.47.1.1 255.255.255.252
no ip directed-broadcast
clock rate 56000
no ip mroute-cache
!
interface Serial1
no ip address
no ip directed-broadcast
shutdown
!
!
no ip classless
ip route 192.168.3.0 255.255.255.0 202.47.2.2
ip route 192.168.2.0 255.255.255.0 202.47.1.2
!
!
!
line con 0
password amal
login
line aux 0
line vty 0 4
password amal
login
!
end
=======================
router3#show running-config
Current configuration:
!
version 12.0
service timestamps debug uptime
service timestamps log uptime
no service password-encryption
!
hostname router3
!
!
!
ip subnet-zero
!
interface Ethernet0
ip address 192.168.2.1 255.255.255.0
no ip directed-broadcast
!
interface Serial0
ip address 202.47.2.1 255.255.255.252
no ip directed-broadcast
shutdown
clock rate 56000
!
interface Serial1
ip address 202.47.1.2 255.255.255.252
no ip directed-broadcast
no ip mroute-cache
!
!
no ip classless
ip route 192.168.3.0 255.255.255.0 202.47.2.2
ip route 192.168.1.0 255.255.255.0 202.47.1.1
!
!
!
line con 0
password amal
login
line aux 0
line vty 0 4
password amal
login
!
end
=========================
router4#show running-config
Current configuration:
!
version 12.0
service timestamps debug uptime
service timestamps log uptime
no service password-encryption
!
hostname router4
!
!
!
ip subnet-zero
!
interface Ethernet0
ip address 192.168.3.0 255.255.255.0
no ip directed-broadcast
!
interface Serial0
no ip address
no ip directed-broadcast
shutdown
!
interface Serial1
ip address 202.47.2.2 255.255.255.252
no ip directed-broadcast
no ip mroute-cache
!
!
no ip classless
ip route 192.168.2.0 255.255.255.0 202.47.2.1
ip route 192.168.1.0 255.255.255.0 202.47.1.1
!
!
!
line con 0
password amal
login
line aux 0
line vty 0 4
password amal
login
!
end