10 November 2009

Router Simple NAT gateway



And Here’s the Running Config for the configuration :

R0#show run
!
hostname R-Gateway
!
!
interface FastEthernet0/0
description *** Remote Connection ***
ip address 10.8.8.211 255.255.255.0
ip nat outside
duplex auto
speed auto
!
ip name-server 202.47.78.8
ip name-server 202.47.78.9
!
interface Ethernet1/0
description *** LAN Connection ***
ip address 192.168.10.1 255.255.255.0
ip nat inside
half-duplex
!
ip classless
ip route 0.0.0.0 0.0.0.0 10.8.8.1
ip http server
!
!
R0#
R0y#ping www.google.com

Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 216.239.61.104, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 84/110/144 ms

28 August 2009

restart services debian

amal:/etc/tinydns/env# svc -d /service/*
amal:/etc/tinydns/env# svc -u /service/*
amal:/etc/tinydns/env# svstat /service/
/service/: unable to open supervise/ok: file does not exist
amal:/etc/tinydns/env# svstat /service/*

15 February 2009

Instaling Virtual Box and Seting more Tap interface in Ubuntu

Installing VirtualBox OSE on Ubuntu 7.10

#sudo apt-get update
#sudo apt-get install virtualbox-ose virtualbox-ose-source

Install VirtualBox OSE kernel module:

sudo apt-get install module-assistant
sudo m-a prepare
sudo m-a a-i virtualbox-ose
sudo modprobe vboxdrv

Automatically load the kernel module:

sudo gedit /etc/modules

Then add:

vboxdrv

taro nama User “vboxusers” group:

sudo adduser [your username] vboxusers

To run VirtualBox OSE, you can click Applications → System Tools → InnoTek VirtualBox menu item.

if u get error message ufter load iso Operation System like :

VBox status code: -1909 VERR_VM_DRIVER_NOT_ACCESSIBLE

fix with this command

sudo chmod 666 /dev/vboxdrv


Configuration Sub interface ini Ubuntu

At first let’s install the needed software:

$ sudo apt-get install bridge-utils uml-utilities

The virtual network interface is configured with the package uml-utilities. uml stands for User Mode Linux, so understandably the package is preconfigured for use with User Mode Linux. In order to work correctly with VirtualBox, in /etc/network/if-pre-up.d/uml-utilities replace

chown root:uml-net /dev/net/tun

with

chown root:vboxusers /dev/net/tun

auto lo
iface lo inet loopback

auto tap0
iface tap0 inet manual
tunctl_user ts
uml_proxy_arp 10.8.8.237
uml_proxy_ether eth0

auto tap1
iface tap1 inet manual
tunctl_user ts
uml_proxy_arp 10.8.8.237
uml_proxy_ether eth0

auto tap2
iface tap2 inet manual
tunctl_user ts
uml_proxy_arp 10.8.8.237
uml_proxy_ether eth0

auto tap3
iface tap3 inet manual
tunctl_user ts
uml_proxy_arp 10.8.8.237
uml_proxy_ether eth0

auto tap4
iface tap4 inet manual
tunctl_user ts
uml_proxy_arp 10.8.8.237
uml_proxy_ether eth0

auto tap5
iface tap5 inet manual
tunctl_user ts
uml_proxy_arp 10.8.8.237
uml_proxy_ether eth0

auto tap6
iface tap6 inet manual
tunctl_user ts
uml_proxy_arp 10.8.8.237
uml_proxy_ether eth0

auto tap7
iface tap7 inet manual
tunctl_user ts
uml_proxy_arp 10.8.8.237
uml_proxy_ether eth0

auto tap8
iface tap8 inet manual
tunctl_user ts
uml_proxy_arp 10.8.8.237
uml_proxy_ether eth0

auto tap9
iface tap9 inet manual
tunctl_user ts
uml_proxy_arp 10.8.8.237
uml_proxy_ether eth0

auto tap10
iface tap10 inet manual
tunctl_user ts
uml_proxy_arp 10.8.8.237
uml_proxy_ether eth0

auto eth0
iface eth0 inet static
address 10.8.8.237
netmask 255.255.255.0
gateway 10.8.8.1

###########pakai yang ini untuk bridge 1 interface ##########
#auto br0
#iface br0 inet static
#address 10.8.8.234
#netmask 255.255.255.0
#bridge_ports eth0 tap0

#####pakai configuration yang ini untuk bridge banyak interface
auto br0
iface br0 inet dhcp
bridge_ports eth0 tap0 tap1 tap2 tap3 tap4 tap5 tap6 tap7 tap8 tap9 tap10
bridge_maxwait 0


Sumber Cerita : http://feryjunaedi.wordpress.com/

08 January 2009

VIm Edit comman

Vim A Editing command text A quick recap of the commands you learned here:

1. Save file - “:w”
2. Quit file without saving - “:q”
3. Save and quit file - “:wq”
4. Go into insert mode - “i”
5. Go into command mode - ESC
6. Delete word - “dw”
7. Delete line - “dd”
8. Undo change - “u”

06 January 2009

Seuntai Kata Buat PALESTINA Kota Q

Kota Jihad

Di kala waktu terus menghilang
merampas semua yang di indah
kota yang dulu penuh bunga
brubah menjadi neraka dunia ladang surga

kota yang dulu hijau pekat
membuat mu kehilangan rupa
yang biasa datang membangunkan pagi
sekarang sudah terbiasa membangunkan malam

kota kebangkitan penuh darah
menyemangatkan darah - darah islam
kota yang penuh ledakan
tidak menghentikan darah untuk berjuang

misil misil yang seakan mengamuk
menjadikan luka tiket untuk ke surga
peluru peluru yang berterbangan seakan setan
membuat darah - darah islam menemui kebangkitan

Karya: Amal Hamzah

10 November 2009

Router Simple NAT gateway



And Here’s the Running Config for the configuration :

R0#show run
!
hostname R-Gateway
!
!
interface FastEthernet0/0
description *** Remote Connection ***
ip address 10.8.8.211 255.255.255.0
ip nat outside
duplex auto
speed auto
!
ip name-server 202.47.78.8
ip name-server 202.47.78.9
!
interface Ethernet1/0
description *** LAN Connection ***
ip address 192.168.10.1 255.255.255.0
ip nat inside
half-duplex
!
ip classless
ip route 0.0.0.0 0.0.0.0 10.8.8.1
ip http server
!
!
R0#
R0y#ping www.google.com

Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 216.239.61.104, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 84/110/144 ms

28 August 2009

restart services debian

amal:/etc/tinydns/env# svc -d /service/*
amal:/etc/tinydns/env# svc -u /service/*
amal:/etc/tinydns/env# svstat /service/
/service/: unable to open supervise/ok: file does not exist
amal:/etc/tinydns/env# svstat /service/*

15 February 2009

Instaling Virtual Box and Seting more Tap interface in Ubuntu

Installing VirtualBox OSE on Ubuntu 7.10

#sudo apt-get update
#sudo apt-get install virtualbox-ose virtualbox-ose-source

Install VirtualBox OSE kernel module:

sudo apt-get install module-assistant
sudo m-a prepare
sudo m-a a-i virtualbox-ose
sudo modprobe vboxdrv

Automatically load the kernel module:

sudo gedit /etc/modules

Then add:

vboxdrv

taro nama User “vboxusers” group:

sudo adduser [your username] vboxusers

To run VirtualBox OSE, you can click Applications → System Tools → InnoTek VirtualBox menu item.

if u get error message ufter load iso Operation System like :

VBox status code: -1909 VERR_VM_DRIVER_NOT_ACCESSIBLE

fix with this command

sudo chmod 666 /dev/vboxdrv


Configuration Sub interface ini Ubuntu

At first let’s install the needed software:

$ sudo apt-get install bridge-utils uml-utilities

The virtual network interface is configured with the package uml-utilities. uml stands for User Mode Linux, so understandably the package is preconfigured for use with User Mode Linux. In order to work correctly with VirtualBox, in /etc/network/if-pre-up.d/uml-utilities replace

chown root:uml-net /dev/net/tun

with

chown root:vboxusers /dev/net/tun

auto lo
iface lo inet loopback

auto tap0
iface tap0 inet manual
tunctl_user ts
uml_proxy_arp 10.8.8.237
uml_proxy_ether eth0

auto tap1
iface tap1 inet manual
tunctl_user ts
uml_proxy_arp 10.8.8.237
uml_proxy_ether eth0

auto tap2
iface tap2 inet manual
tunctl_user ts
uml_proxy_arp 10.8.8.237
uml_proxy_ether eth0

auto tap3
iface tap3 inet manual
tunctl_user ts
uml_proxy_arp 10.8.8.237
uml_proxy_ether eth0

auto tap4
iface tap4 inet manual
tunctl_user ts
uml_proxy_arp 10.8.8.237
uml_proxy_ether eth0

auto tap5
iface tap5 inet manual
tunctl_user ts
uml_proxy_arp 10.8.8.237
uml_proxy_ether eth0

auto tap6
iface tap6 inet manual
tunctl_user ts
uml_proxy_arp 10.8.8.237
uml_proxy_ether eth0

auto tap7
iface tap7 inet manual
tunctl_user ts
uml_proxy_arp 10.8.8.237
uml_proxy_ether eth0

auto tap8
iface tap8 inet manual
tunctl_user ts
uml_proxy_arp 10.8.8.237
uml_proxy_ether eth0

auto tap9
iface tap9 inet manual
tunctl_user ts
uml_proxy_arp 10.8.8.237
uml_proxy_ether eth0

auto tap10
iface tap10 inet manual
tunctl_user ts
uml_proxy_arp 10.8.8.237
uml_proxy_ether eth0

auto eth0
iface eth0 inet static
address 10.8.8.237
netmask 255.255.255.0
gateway 10.8.8.1

###########pakai yang ini untuk bridge 1 interface ##########
#auto br0
#iface br0 inet static
#address 10.8.8.234
#netmask 255.255.255.0
#bridge_ports eth0 tap0

#####pakai configuration yang ini untuk bridge banyak interface
auto br0
iface br0 inet dhcp
bridge_ports eth0 tap0 tap1 tap2 tap3 tap4 tap5 tap6 tap7 tap8 tap9 tap10
bridge_maxwait 0


Sumber Cerita : http://feryjunaedi.wordpress.com/

08 January 2009

VIm Edit comman

Vim A Editing command text A quick recap of the commands you learned here:

1. Save file - “:w”
2. Quit file without saving - “:q”
3. Save and quit file - “:wq”
4. Go into insert mode - “i”
5. Go into command mode - ESC
6. Delete word - “dw”
7. Delete line - “dd”
8. Undo change - “u”

06 January 2009

Seuntai Kata Buat PALESTINA Kota Q

Kota Jihad

Di kala waktu terus menghilang
merampas semua yang di indah
kota yang dulu penuh bunga
brubah menjadi neraka dunia ladang surga

kota yang dulu hijau pekat
membuat mu kehilangan rupa
yang biasa datang membangunkan pagi
sekarang sudah terbiasa membangunkan malam

kota kebangkitan penuh darah
menyemangatkan darah - darah islam
kota yang penuh ledakan
tidak menghentikan darah untuk berjuang

misil misil yang seakan mengamuk
menjadikan luka tiket untuk ke surga
peluru peluru yang berterbangan seakan setan
membuat darah - darah islam menemui kebangkitan

Karya: Amal Hamzah